Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10172 closed bug (wontfix)

Harmonizing the "keypress" event between browsers

Reported by: anonymous Owned by:
Priority: low Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Change History (2)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledevent
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

Recommend:

$('input').live('keydown', function(event) {
    if ( event.which === 37 ) {
        console.log("left key pressed");
    }
});

And also: http://api.jquery.com/keypress/

Note: as the keypress event isn't covered by any official specification, the actual behavior encountered when using it may differ across browsers, browser versions, and platforms.

comment:2 Changed 7 years ago by dmethvin

#12469 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.