Bug Tracker

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10166 closed bug (duplicate)

click() on a checkbox still doesn't appear checked(or unchecked) before the handlers call

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

in windows 7 using FF 5.0 & IE 8.0 a $(checkbox).click() still calls all the handlers before changing status. this doesn't correctly simulate the 'mouse click' call sequence. can you confirm? if wrong, I apologize. Many thanks.

Change History (6)

comment:1 Changed 8 years ago by anonymous

ie: var checkbox = ...; $(checkbox).click (function () {alert((checkbox.checked)?"true":"false");}); $(checkbox).click(); if i'm right this should alert "false" with the checkbox still unchecked, then check it.

comment:2 Changed 8 years ago by Rick Waldron

Component: unfiledevent
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 7 years ago by dmethvin

Resolution: invalid
Status: closedreopened

comment:5 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: reopenedclosed

comment:6 Changed 7 years ago by dmethvin

Duplicate of #3827.

Note: See TracTickets for help on using tickets.