Bug Tracker

Opened 10 years ago

Closed 10 years ago

#10156 closed bug (invalid)

Events not working in Windows phone 7 web browser control

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

I am wrapping up asp.net web site in a browser control on windows phone 7 to give native app feel. But the problem is JQuery events are not working in browser control whereas the same is working fine in IE browser of the mobile.

To explain the issue - Lets say I have a web page called 'index.html'. and this page contains a hyperlink tag

<a href="#">Test Link </a>

Now I am using JQuery to overwrite this hyperlink click event. Below is the code

$("a")

.click(function (event) {

event.preventDefault(); prevents link to be redirected document.location.href = "http://www.yahoo.com"; return -1;

});

In Windows Phone 7 browser control when I click on the link nothing is happening. But the same code is working fine in IE browser of the mobile. I turned option IsScriptEnabled to true for the browser control but still its doesnt work. Is there any way that I can fix this?

Change History (4)

comment:1 Changed 10 years ago by Rick Waldron

Owner: set to [email protected]
Status: newpending

We have no immediate resources to test this, but my first thought is that something about your handler is broken. First, what is the significance of returning -1? Perhaps you meant to return false? -1 does not equal false.

Can you run this: http://jsfiddle.net/rwaldron/as2Gc/show/ in your browser control and report back the result?

comment:2 Changed 10 years ago by Rick Waldron

Component: unfiledevent

comment:3 Changed 10 years ago by dmethvin

Is there a reason why you return -1 from the event handler? It's rather unusual.

comment:4 Changed 10 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.