Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10153 closed bug (duplicate)

jquery 1.6.2( could affect more versions) compressed breaks when minified on Debian?

Reported by: me@… Owned by: me@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

I am not sure what causes this as I have been unable to reproduce, but some clients have been able to. (Esp on debian 6)

Steps to reproduce for some people:

  1. Create an html file with just the compressed version of jquery included
  2. Go to site and notice that an error occurs. I have seen others get "Missing { after property list" which

Reference: http://stackoverflow.com/questions/6680244/debian-all-browsers-jquery-compressed-breaks-all-js-but-uncompressed-works-fin/7216876#7216876

If anyone has any suggestions on how to reproduce more effectively I would love to know

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to me@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

jsFiddle allows you to specify additional resources, so please use a copy of the "broken" minified source.

comment:2 Changed 8 years ago by dmethvin

Resolution: invalid
Status: pendingclosed

Your minifier is incorrectly seeing the /* inside a QUOTED string as the beginning of a multi-line Javascript comment. PLEASE DO NOT TAUNT HAPPY FUN JQUERY with a broken minifier; instead use the properly-minified version available at code.jquery.com or any of the CDNs.

comment:3 Changed 8 years ago by dmethvin

Resolution: invalid
Status: closedreopened

comment:4 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by dmethvin

Duplicate of #10098.

Note: See TracTickets for help on using tickets.