Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10151 closed bug (invalid)

$(iframe[name="browser"]').attr('src') not working correctly.

Reported by: jose@… Owned by: jose@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have an iframe named 'browser'. Inside it, I load allways same-domain urls.

So I have:

function iframeloaded()
{ var arr = $('iframe[name="browser"]').attr('src'); alert(arr); }
<iframe name="browser" src="/home" onLoad="iframeloaded();"></iframe>

If i use links from the parent page, arr contains the correct updated url. If I use jquery.click(parent.replace('/home')) inside the iframe, arr contains the correct updated url. BUT If i use html links inside the iframe, arr does NOT updates correctly.

Basic JS frames[0].location works fine allways.

Change History (3)

comment:1 Changed 7 years ago by anonymous

Not a bug. HTML links are not jQuery driven events. Anyway, its strange, cause even arr baing local and using html links, iframeloaded allways popup a previously visited url.

comment:2 Changed 7 years ago by dmethvin

Owner: set to jose@…
Status: newpending

This description isn't at all clear to me. Please create a test case.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.