Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10147 closed bug (fixed)

KeyError: 'captcha_redirect'

Reported by: gcaufy Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'acbecaeecc547133b7d433eb',
 'recaptcha_challenge_field': u'03AHJ_Vusq9jRxFtatRrMOwVwscg-4oprIyTUpgYz5RsfNt7dAMp6x7Vf2fJvId8ogvsJwfEPorqALFwU_b2HdiikwVJDzzUMJ8t6eeMqvfN1z1KaxSC4M4I6_vx0Gw543P7wGo0F7fIU_2Kehr20JnE8mO7e3rd-UKA',
 'recaptcha_response_field': u'PIegtonn hers'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: fixed
Status: newclosed

Looks like there was a temporary problem with the captcha service, I think it has been fixed now.

Note: See TracTickets for help on using tickets.