Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10125 closed bug (invalid)

Canvas creation Height/Div problem

Reported by: Py Owned by:
Priority: low Milestone: None
Component: core Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

When creating a canvas using the following:

$("<canvas/>",{"height":100,"width":100});

You would expect a canvas created with it's width and height set to the value specified.

However, the current implementation transform those width and height to css width and height.

To implement a correct canvas, the following is needed.

$("<canvas/>").attr({"height":100,"width":100});

Change History (4)

comment:1 Changed 8 years ago by Py

comment:2 Changed 8 years ago by timmywil

Component: unfiledcore
Priority: undecidedlow
Resolution: invalid
Status: newclosed

This is the desired behavior. Use the .attr() method to specifically set the width/height attributes. As you can see from the fiddle, the style tag takes precedence over the width/height attributes. It is used for that reason.

comment:3 Changed 8 years ago by addyosmani

#10040 is a duplicate of this ticket.

comment:4 Changed 8 years ago by Rick Waldron

#11715 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.