Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 8 years ago

#1011 closed bug (worksforme)

.fadeIn() broken in Firefox 3

Reported by: voyagerfan5761 Owned by:
Priority: major Milestone: 1.2.2
Component: effects Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

As of Gran Paradiso Alpha 2, jQuery's fade-in effect does not work.

Change History (15)

comment:1 Changed 13 years ago by voyagerfan57

I should mention that the site URL (you can use this to see for yourself what happens) is http://web.augsburg.edu/~werlm/cada/?msg=outnote .

comment:2 Changed 13 years ago by cdomigan

Perhaps we should wait for at least a beta of FF3 before fixing issues. In alpha it's probably too much of a moving target.

comment:3 Changed 13 years ago by john

I'm in the process of moving the jQuery test suite into the Mozilla branch. This is an obvious regression in Firefox and shouldn't have happened. I'll try to localize it and let you know what's up.

comment:4 Changed 13 years ago by john

Summary: FF3 support.fadeIn() broken in Firefox 3

comment:5 Changed 13 years ago by voyagerfan57

Thanks. I'll keep checking back here daily, but if you make a serious breakthrough you can email me at [my dev.jquery.com username]@gmail.com . Thanks for the quick response. Mozilla isn't releasing the update until this fall, with a third alpha due late this month. I guess there's time. I just jumped because I use this function for critical interface components on my site. It is fixable with a simple recode, but...I like the appearance, y'know? Best of luck tracking this down!

comment:6 Changed 13 years ago by voyagerfan57

I've found some more things. I don't know if they belong here, but both ShortAccesskey and TableSorter are broken in FF3 (TableSorter version as of 2006-08-21; No date found for ShortAccesskey). This definitely extends past .fadeIn().

comment:8 in reply to:  7 Changed 13 years ago by voyagerfan57

In reply to haoracks's comment: Could someone please remove this spam from the database? Here I thought someone had actually paid my report some mind lately...

comment:11 in reply to:  10 Changed 13 years ago by voyagerfan57

Aaaah! More spam. Can we get rid of this, too, please? Thanks in advance, John (or whoever is taking care of this stuff).

comment:12 in reply to:  description ; Changed 13 years ago by voyagerfan57

Replying to voyagerfan5761:

As of Gran Paradiso Alpha 2, jQuery's fade-in effect does not work.

I should note that I just tested with Gran Paradiso Alpha 5, and the code still does not work. To clarify, I'm using the fadeTo() function like this: $('div.msg').fadeTo(3000, 1);

comment:13 in reply to:  12 Changed 13 years ago by voyagerfan57

Replying to voyagerfan5761:

Replying to voyagerfan5761:

As of Gran Paradiso Alpha 2, jQuery's fade-in effect does not work.

I should note that I just tested with Gran Paradiso Alpha 5, and the code still does not work. To clarify, I'm using the fadeTo() function like this: $('div.msg').fadeTo(3000, 1);

Another update: I just downloaded the nightly release available on this date (06/17/07) and tested it in FF3a5. The fade still does not work.

comment:14 in reply to:  1 Changed 13 years ago by voyagerfan57

This URL will no longer cause the banner to try to appear. You must now make an invalid login attempt to cause a banner to appear.

Replying to voyagerfan5761:

I should mention that the site URL (you can use this to see for yourself what happens) is http://web.augsburg.edu/~werlm/cada/?msg=outnote .

comment:15 Changed 13 years ago by voyagerfan57

OK, this bug seems to have garnered no response at all...

Let me just note that I have frozen the site in question on the last 1.1.x release because of some compatibility problems with jQuery 1.2.x and the Interface plugin. As of FF3b1, the fadeIn() method still does not work.

On further investigation, I discovered that .fadeIn() does not work even in FF2. I have been using .fadeTo() instead. Not even switching to jQuery 1.2.1 solves the problem; the method still fails. I do not know if it is a factor of my CSS, the structure of the page, or what, but nothing works.

As a matter of correction, it is .fadeTo() that hasn't been working in Firefox 3, and .fadeIn() and .fadeOut() do not work in FF2 (I have not had time to test in the latest FF3).

The title of this bug is in need of a change, I think.

comment:16 Changed 13 years ago by davidserduke

need: Review

I think FF3 was just released as a beta the other day. Is this still a problem with FF3 beta? I'm afraid to install it since I've had issues with multiple version FF installations and I don't have a spare machine at the moment to test it.

comment:17 Changed 13 years ago by davidserduke

Milestone: 1.1.31.2.2
need: ReviewTest Case
Resolution: worksforme
Status: newclosed

This has now been tested on Firefox 3 Beta 1 and works fine for me.

http://docs.jquery.com/Effects/fadeIn#speedcallback

Hopefully whatever problem you are seeing is gone. If not please reopen the ticket with a new test case.

comment:18 in reply to:  17 Changed 13 years ago by voyagerfan57

Replying to davidserduke:

This has now been tested on Firefox 3 Beta 1 and works fine for me.

http://docs.jquery.com/Effects/fadeIn#speedcallback

Hopefully whatever problem you are seeing is gone. If not please reopen the ticket with a new test case.

As I mentioned above, this bug has been mistitled for the last however many months. I've been using fadeTo(), not fadeIn(). I don't particularly have time to test it now, but I will in the next week or two, and will post my test code snippet. Until then, I'll leave the bug closed. Meanwhile, I'm not quite sure how to change the bug title...

Note: See TracTickets for help on using tickets.