Bug Tracker

Opened 10 years ago

Closed 10 years ago

#10073 closed bug (worksforme)

attr('disabled') always return undefine

Reported by: Vitaliy Medvedev, [email protected] Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

attr('disabled') always return undefined - http://jsfiddle.net/ZSnn8/

compare with results in jquery 1.6.0 - http://jsfiddle.net/bDXvK/

Change History (1)

comment:1 Changed 10 years ago by addyosmani

Component: unfiledattributes
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

This has been fixed in jQuery (edge). I've verified that at least in Chrome 13 with 1.6.2, undefined is returned for attr('disabled') (using the examples cited) but 1.6.3 should contain the fix as long as it isn't backed out.

I haven't been able to locate the commit responsible for this, but here's a test case using edge that shows your example working fine: http://jsfiddle.net/znyvN/.

(Note: I don't consider this a dupe of #9927 as there are confirmed diffs between 1.6.2 and edge, whilst that ticket specifically deals with the pre/post 1.6.x prop/attr issues).

Note: See TracTickets for help on using tickets.