Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10048 closed bug (duplicate)

Using find('*') on HTML5 tags includes closing tags in IE7 & 8

Reported by: Motty Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

When using find('*') in IE7 & 8, almost all HTML5 closing tags are included (except for <ruby>)

http://jsfiddle.net/L7d9g/4/

This may be related to http://bugs.jquery.com/ticket/10047 but I opened a separate ticket just in case it isn't.

This appears to be happening in all jQuery versions.

Change History (3)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is because the tags are seen as invalid, notice what happens when Modernizr is included:

http://jsfiddle.net/L7d9g/5/

Any code that is expecting HTML5 tags to work should be including a shiv. This is really under the umbrella of the HTML5 ticket.

comment:2 Changed 8 years ago by dmethvin

Duplicate of #6845.

Version 0, edited 8 years ago by dmethvin (next)

comment:3 Changed 8 years ago by dmethvin

#10047 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.