Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10047 closed bug (duplicate)

Closing embed tag found in IE7 & 8

Reported by: Motty Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

When trying to find all contained elements, IE7 and IE8 also finds the closing embed tag: http://jsfiddle.net/Mottie/L7d9g/2/

// includes /embed in IE7&8
$(selector).find('*')

This occurs in all jQuery versions

Change History (3)

comment:1 Changed 8 years ago by Motty

I'm not sure if this is related, but it appears that most of the new HTML5 tags also include the closing tag (the only exception is <ruby>) http://jsfiddle.net/L7d9g/4/ - I'll open a new ticket, just in case.

Last edited 8 years ago by Motty (previous) (diff)

comment:2 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Not quite the same bug but related, and not something jQuery can do much about; IE needs a shiv.

comment:3 Changed 8 years ago by dmethvin

Duplicate of #10048.

Note: See TracTickets for help on using tickets.