Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10030 closed bug (duplicate)

IE 7 only - jQuery core "finally {"

Reported by: toby@… Owned by: toby@…
Priority: low Milestone: None
Component: deferred Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery from CDN loaded into Wordpress 3.2, works perfectly in all browsers except IE7.

Script debugger reports that the jQuery core is responsible, with this error:

"Object doesn't support this property or method"

The function it seems to get caught on is:

finally{b=[e,f],c=0}

minified file and uncompressed causes the same error, and exists in this version and 1.5.

Change History (5)

comment:1 Changed 8 years ago by timmywil

Component: unfileddeferred
Owner: set to toby@…
Priority: undecidedlow
Status: newpending

This may be an example where try/finally causes a problem in IE7. We have not been able to reproduce the issue with a test case yet, however, so if you could, please provide a reduced test case in any way possible. If it can be reproduced on http://jsfiddle.net, that is preferred.

comment:2 Changed 8 years ago by anonymous

the problem is when some settings for display js error open

any way i had the same problem and solve the problem The error you're getting is due to jQuery needing to call the function resolveWith which contains a try - finally without a catch block. Until IE9, this is not supported by IE and causes the error:

in the 1.6.2 min version at the "try" is without catch

try{while(a[0])a.shift().apply(e,f)}finally{b=[e,f],c=0}

i changed it to

try{while(a[0])a.shift().apply(e,f)}catch(e){}finally{b=[e,f],c=0} and it work with no error

comment:3 Changed 8 years ago by Ben

I've met the same problem on IE8. IE<9 need to have at least one catch before a finally.

comment:4 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

comment:5 Changed 8 years ago by Rick Waldron

Duplicate of #9033.

Note: See TracTickets for help on using tickets.