Bug Tracker

Opened 8 years ago

Closed 7 years ago

#10022 closed bug (invalid)

In firefox5.0 or chrome 13 $('[required=true]:visible').size() is 0

Reported by: xudabai@… Owned by: xudabai@…
Priority: low Milestone: None
Component: selector Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

In firefox5.0 or chrome 13 $('[required=true]:visible').size() is 0 but in ie9 it is right. And the $('[required=true]') is right in ff5 chrome13 IE9 and the $('[type=text]:visible') is right in ff5 chrome ie9, and $('[required=true]').filter(':visible') is right.

But why $('[required=true]:visible') is not work in ff5 chrome 13

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledselector
Owner: set to xudabai@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket! (ideally this should reproduce the behaviour you are mentioning in your ticket)

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/

Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.