Bug Tracker

Opened 10 years ago

Closed 10 years ago

#10013 closed bug (invalid)

Memory leaks about 4 or 8kB on each ajax call.

Reported by: christophorus Owned by: christophorus
Priority: undecided Milestone: None
Component: ajax Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

On all browsers (Opera, IE, FF, Chrome) I have observed the memory leaks about 4 or 8kB on each ajax call. The php returns proper simple json text.

Working sample: http://macs.pl.tmm.pl/gold/player/ajaxtest.html

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 StrictEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en"> <head> <title>Test</title>

<script type="text/javascript" src="jquery_ui/js/jquery1.6.2.js"></script> </head> <body>

<script>

var s = function(){

};

var f = function(){

};

var t = function(){

$.ajax({

type: "POST", data: , async: true, url: "http://macs.pl.tmm.pl/gold/progress.php", dataType: "json", timeout: 10000, cache: false, success: s, error: f

});

};

setInterval(t,5000);

</script>

</body> </html>

Thank you for assistance.

Krzys

Change History (10)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledajax
Owner: set to christophorus
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by Rick Waldron

Additionally, what tools or methods are you using to observe these "leaks". I just took 6 heap snapshots, one per request over 6 requests and the heaps are all the same

comment:3 in reply to:  2 Changed 10 years ago by christophorus

Status: pendingnew

Replying to rwaldron: I have used the resource monitor (on Windows platform). I left the endless loop for 1 hour and comparing amount memory before and after. This is very strange for me, since nobody reported the same issue.

comment:4 Changed 10 years ago by dmethvin

#10044 is a duplicate of this ticket.

comment:5 Changed 10 years ago by dmethvin

comment:6 Changed 10 years ago by dmethvin

Status: newpending

I am not seeing a leak with that test case. christophorus, can you verify that and perhaps try to change that test case so that it leaks?

comment:7 in reply to:  6 Changed 10 years ago by christophorus

Status: pendingnew

Thank you for the test. I made following test: your case on Chrome(last), FF(6) and IE(9), and the result is that memory is (in my opinion) on Chrome and FF but not using IE.9. I made this test on Vista(32). Please make me advice how I can proceed now. BTW. my case doesn't leak on IE(9) as well.

comment:8 Changed 10 years ago by dmethvin

Status: newpending

Did you mean to attach a link to a test case?

comment:9 Changed 10 years ago by andresclari

I can confirm the bug with @dmethvin test case on FF 6

comment:10 Changed 10 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.