Bug Tracker

Opened 8 years ago

Closed 8 years ago

#10002 closed bug (invalid)

replaceWith() remove() = "PAGE CANNOT BE SEEN" in IE 7 and below

Reported by: Elrinth Owned by: Elrinth
Priority: low Milestone: None
Component: manipulation Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

To reproduce this:

<span id="weWannaRemoveThis"> <script type="text/javascript"> DoStuff("weWannaRemoveThis"); </script> </span> <script type="text/javascript"> function DoStuff(i_where) {

This below causes "Webpage can't be viewed in this browser" $("#" + i_where).replaceWith("test"); $("#" + i_where).remove();

} </script>

ONLY TESTED ON IETester with IE7 tab, but our clients say there is similar results on their real IE7! This is tested in jquery 1.6.2 and 1.5.3. Didn't test any other versions than that. To solve the issue, I simply don't remove the javascript. I used append/before/prepend/after instead and let the javascript code stay.

Change History (3)

comment:1 Changed 8 years ago by anonymous

seems that which I wrote was destroyed by your editor... I had written comment on some of the lines (two slashes)... so now the code will be broken because your text editor ruined it. :)

But I hope you guys understand what I'm trying to do.

I only did replaceWith and commented out remove for you guys to see. but the comment in the text was removed by the jquery bug-ticket textarea.

comment:2 Changed 8 years ago by timmywil

Component: unfiledmanipulation
Owner: set to Elrinth
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket. Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, we've created this boilerplate: http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.