Bug Tracker

Custom Query (13852 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (46 - 48 of 13852)

Ticket Resolution Summary Owner Reporter
#3724 duplicate Clone on SSL with Anchor Tag cblaze22
Description

I recently ran into a problem with the clone function and SSL with a anchor tag. The problem was IE kept showing that unsecure items were on a page that contained htts:// in the protocol. Searching the html there was nothing. I narrowed the problem down to cloning a anchor . I read that some javascript may cause this issue with SSL enabled sites. My fix was to create the anchor tag by scratch and use that instead.

#3725 invalid Filter expression i.e. $('li:gt(1)') broken since jQuery 1.2.5 dasjan
Description

I've been using a script which works fine with jQuery 1.1 but now had to update to jQuery 1.2.6 for a new script, now the following script doesn't work anymore:

function ndxz_expanding_loader()

{

var speed = 200;

var item_title = new Array(); var items = new Array(); var i = 0; $("#menu ul").each(function() {

items[i] = $("#menu ul").eq(i).children().filter(function (index) { return index > 0; }); /* v1 - hide items if not active */ if (items[i].is(".active") == false) { items[i].hide(); } /* v2 - hide all */ items[i].hide(); apply the clicker $(this).attr('id', 'c' + i); $(this).children(":first").css({ cursor: 'pointer' }); $$(this).attr('onclick', "$('ul#c" + i + " li:gt(0)').toggle(" + speed + ");$('#content').hide();");

i++;

});

}

Script is also viewable here: http://dev.rocho.org/nico-jquery/nico-admin/site/js/menu.js

It works correctly in the current Firefox 3, but not in current versions of Safari, IE and Chrome.

I also tried changing the line:

$(this).attr('onclick', "$('ul#c" + i + " li:gt(0)').toggle(" + speed + ");$('#content').hide();");

to:

$(this).attr('onclick', "$('ul#c" + i + " li:not(:first-child)').toggle(" + speed + ");$('#content').hide();");

and:

$(this).attr('onclick', "$('ul#c" + i + " li').slice(1).toggle(" + speed + ");$('#content').hide();");

The above examples also don't work.

And then downgraded to 1.2.5 which has the same error, 1.2.4 was not released and in jQuery 1.2.3 the script works in all browsers.

I have put up a demo at:

http://dev.rocho.org/nico-jquery

with the version that uses jQuery 1.2.6 only works in FF 3.

If you click on one of the menu items (Arbeiten,Vita, Kontakt) they won't expand on Safari, IE.

#3730 duplicate BUG: input text element hover() in FF Firefox dazz
Description

When you use hover() on an input text element in FF the result is very flaky. As you mouseover it seemingly randomly works correctly or not. (The mouseout event is not always (fired or caught)).

Note: See TracQuery for help on using queries.