Bug Tracker

Ticket #9999 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

one() fires more then once on the same element

Reported by: anotherhero@… Owned by:
Priority: low Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Try clicking at least once with left and once with right mouse buttons.

 http://jsfiddle.net/ck7rK/

The documentation says "Attach a handler to an event for the elements. The handler is executed at most once per element."

Ok it says to an event and not events but I doubt this is working as intended.

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Resolution set to invalid
  • Status changed from new to closed
  • Component changed from unfiled to event

Right, that is correct behavior. The space-delimited syntax is simply a shortcut for binding multiple events. If you wanted something to happen one time on click and something else to happen one time on hover, they would both fire, but they would both fire once.

Note: See TracTickets for help on using tickets.