Bug Tracker

Modify

Ticket #9970 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Typo in ajax.js: status should be jzXHR.status?

Reported by: giova.chi Owned by: jaubourg
Priority: low Milestone: 1.6.3
Component: ajax Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

jquery.js, line 7233

The "status" should be "jqXHR.status" I think

source timestamp: Date: Thu Jun 30 14:16:56 2011 -0400

maybe it passes your tests because that line is not included in the test coverage?

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to giova.chi
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to ajax

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket. Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, we've created this boilerplate:  http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 Changed 3 years ago by giova.chi

  • Status changed from pending to new

it's in the error handling code. I don't know how to make "transport.send(requestHeaders, done);" fail with jsFiddle.

Still, I think it's a bug.

comment:3 Changed 3 years ago by timmywil

  • Status changed from new to pending

Is it perhaps reproducible on a private server?

comment:4 Changed 3 years ago by giova.chi

I think the easiest way is to take a look at the source code. That "status" variable is simply not defined anywhere in the scope. It's very hard to do a unit test for this error handling code, but whoever wrote the code should be able to see the problem very quickly.

I think he wanted to use "jqXHR.status" instead.

comment:5 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:6 Changed 3 years ago by dmethvin

  • Status changed from closed to reopened
  • Resolution invalid deleted

Reopening for jaubourg to get a chance to weigh in.

comment:7 Changed 3 years ago by dmethvin

  • Owner changed from giova.chi to jaubourg
  • Status changed from reopened to assigned

comment:8 Changed 3 years ago by dmethvin

  • Summary changed from jQuery 1.6.2 error to Typo in ajax.js: status should be jzXHR.status?
  • Milestone changed from None to 1.6.3

comment:9 Changed 3 years ago by jaubourg

  • Status changed from assigned to closed
  • Resolution set to fixed

Typo was fixed while investigating #9585.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.