Bug Tracker

Modify

Ticket #9871 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

removeAttr breaking chained functions in IE7

Reported by: Motty Owned by:
Priority: low Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Using removeAttr() seems to ignore other chained functions in jQuery 1.6.1+

Demo:  http://jsfiddle.net/phfZT/1/

Also, the input doesn't get focused in the main demo, but the val does change:  http://api.jquery.com/removeAttr/

It works fine when using 1.5.2 and older versions of jQuery

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to event

I don't see a problem with this one:  http://jsfiddle.net/timmywil/phfZT/2/

However, the problem with the focus in IE7 is a known issue and patches are welcome. The behavior may change in the event rewrite for 1.7.  http://jsfiddle.net/timmywil/qVUWN/

comment:2 Changed 3 years ago by timmywil

Duplicate of #8679.

comment:3 Changed 3 years ago by Motty

How is this a duplicate of #8679? When I run this demo  http://jsfiddle.net/timmywil/phfZT/2/ I see both outputs as zero in IE7.

Last edited 3 years ago by Motty (previous) (diff)

comment:4 Changed 3 years ago by timmywil

@Motty: this ticket is really reporting two separate issues. The first is worksforme because I can't reproduce a problem. The second is a duplicate of #8679 because it is due to calling focus in the callback.

comment:5 Changed 3 years ago by timmywil

Now seeing your edited comment. I see 1 then 0 in IE7. Not sure what is different then.

comment:6 Changed 3 years ago by Motty

This is what I'm seeing:  http://i51.tinypic.com/m8h5i1.jpg

Version 0, edited 3 years ago by Motty (next)

comment:7 Changed 3 years ago by Motty

Interestingly, if I put the removeAttr before the addClass, it works. I'll just use that as a workaround then. Thanks!

comment:8 Changed 3 years ago by timmywil

@Motty: yea that's really strange. Your pic looks an awful lot like IE9, but I tested IE9 as well and it works for me there too so I'm not sure how to reproduce.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.