Bug Tracker

Ticket #9835 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

anchor link fails when linking to a page that includes jquery 1.6 +

Reported by: benlivermore Owned by: benlivermore
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Browser: Mobile Safari, iOS 4 OS: iOS 4 Device: iPad 2

Steps to reproduce:

  1. Create an html 5 page that has a paragraph tag with an id and is taller than the height of the viewport and include jquery 1.6 or higher within it.
<html lang="en">
<head>
	<meta charset="utf-8">
	<title>TEST</title>
	<script type="text/javascript" src="http://code.jquery.com/jquery-1.6.2.min.js"></script>
	


</head>
<body>
<p style="height:1024px;">Test out jquery anchor link bug</p>
<p id="test">This anchor should work</p>
<p style="height:1024px;">Test out jquery anchor link bug</p>

</body>
</html>
  1. Link to this page via another html page's "test" anchor via the hash #test

<a href="anchorpage.html?#test">Test bug</a>

  1. Now open up the page from step 2 in the ipad safari browser.
  1. Click the link from step 2.

Expected: I should arrive at the page from step 2 and immediately anchor down to the middle paragraph with the id of "test"

Actual Result: I stay at the top of the page.

Note: this works in jquery 1.5 and 1.4.2 but no longer works in 1.6 +

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to benlivermore
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, I've created this boilerplate:  http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.