Bug Tracker

Modify

Ticket #9822 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

jquery $("#someTRid").attr("for") in ie6 return undefined

Reported by: babysuper Owned by: babysuper
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

in ie6,in my html,there are some tr elements have custome attribute "for",but the $("#someTRid").attr("for") return 'undefine' to me.and if use the $("#someTRid").get(0).getAttribute("for") will return the right value. and if i change the custome attribute to "class",the $("#someTRid").attr("class") will work well.

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to babysuper
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to attributes

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on  http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.