Bug Tracker

Modify

Ticket #9727 (closed bug: worksforme)

Opened 3 years ago

Last modified 3 years ago

$.animate() cannot animate fontSize as documented

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: effects Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

In the documentation here:  http://api.jquery.com/animate/

It shows that fontSize can be animated, however, this is not possible. $.css() works as predicted, even with incremental and decremental type operators += and -=

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to anonymous
  • Status changed from new to pending
  • Component changed from unfiled to effects

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on  http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 3 years ago by addyosmani

  • Priority changed from undecided to low
  • Status changed from closed to reopened
  • Resolution invalid deleted

Re-opening as this was automatically closed by trac-o-bot.

comment:4 Changed 3 years ago by addyosmani

  • Status changed from reopened to closed
  • Resolution set to worksforme

I've tested our fontSize animation examples out in Chrome, Chromium/Dev, Safari and Firefox 5 and they they appear to be working fine without any issues. This even works fine with + ( http://jsfiddle.net/rvZsT/1/) and - ( http://jsfiddle.net/rvZsT/2/).

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.