Bug Tracker

Modify

Ticket #9715 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

ajax have memory leak in firefox and i.e.

Reported by: roberto@… Owned by: roberto@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

i will send a php code, be sure that jquery-1.6.1.js is in the same directory.... start. after +- 6000 counter alert message the memory is about 60mb, at the start of firefox4 it was 30mb... any idea?

i will send code as link since askmetic is spanning my message

Change History

comment:1 Changed 3 years ago by anonymous

... php code at start of page:
	if($_REQUEST['frame']==1)
		die();
	
<html>
<head>
<script language="javascript" src="jquery-1.6.1.js"></script>
</head>
<body>
<script language='javascript'>
var contador=0;
function get_values(){
	jQuery.ajax({
			type: "GET",
			url:"bug.jquery.php",
			data:"frame=1",
			dataType:"text",
			cache:false,
			success:show_values
		});
}
function show_values(){
	contador++;
	if((contador % 2000)==0)
		alert(contador);
	get_values();
}
get_values();	// start loop...
</script>
</body>
</html>

comment:2 Changed 3 years ago by anonymous

i think it´s near to this bug: http://bugs.jquery.com/ticket/6242

comment:3 Changed 3 years ago by timmywil

  • Owner set to roberto@…
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to ajax

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on  http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:4 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.