Bug Tracker

Ticket #9512 (closed bug: worksforme)

Opened 3 years ago

Last modified 3 years ago

Select menu within SPAN tag display error in Safari 4.04/Mac

Reported by: developer@… Owned by: developer@…
Priority: low Milestone: 1.next
Component: effects Version: 1.6.1
Keywords: Cc:
Blocking: Blocked by:

Description

jQuery v1.6.1 and older:

In Safari 4.04/Mac, placing a select menu within a span with the span display set to "none", when displaying the span/menu using fadeIn() the complete menu does not display, the bottom section is invisible.

Demo:  http://www.suomedia.com/jquery.html

Will test this later today with Safari 5

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to developer@…
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, I've created this boilerplate:  http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 follow-up: ↓ 4 Changed 3 years ago by anonymous

Why don't you just click on the link above. Its very very simple to do....

comment:3 Changed 3 years ago by rwaldron

I did, but in order to debug the code and test deviations I would have to spend my own personal time re-producing _your_ bug. Also... it says so on the big pink and red box where you filed the ticket.

comment:4 in reply to: ↑ 2 Changed 3 years ago by rwaldron

Replying to anonymous:

Why don't you just click on the link above. Its very very simple to do....

Also, that's not a very nice way to reply to very respectfully asked request.

comment:5 Changed 3 years ago by anonymous

Thats fine, I have my own fix for your bug. You will just have to live with it.

I did take the time to report the bug. I think you expect a little to much, its your development, not mine. I in no wise have the time to learn your IDE.

comment:6 Changed 3 years ago by anonymous

BTW, it is not "_your_" bug, its _yours_ Just take two seconds to look at the source of the demo.

comment:7 Changed 3 years ago by addyosmani

  • Priority changed from undecided to low
  • Resolution set to worksforme
  • Status changed from pending to closed
  • Component changed from unfiled to effects

With respect to the above discussion, please bare in mind that the reason we ask that all ticket submissions include code via jsfiddle.net is so that we can more easily test across browsers or tweak your test case should that be needed.

Forgive rwaldron's tone, but as I'm sure you can appreciate, it's not always easy to strip code from someone elses server in order to produce an editable test.

I've run your code through Safari 5.x and Safari 4.x, but haven't been able to reproduce the issue you're experiencing on the Mac. Kindly double-check your code (or perhaps provide a screenshot of what you're seeing) and we'll do our best to re-evaluate.

comment:8 Changed 3 years ago by anonymous

I just upgraded to Safari 5 which does not show the problem. I think its a Safari/Mac problem rather than jQuery. Definitely there in Safari 4.04 with the simplest code to test it. Perhaps its only there on a 13" Macbook Pro running Snow Leopard... who knows?

Note: See TracTickets for help on using tickets.