Bug Tracker

Modify

Ticket #8874 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

IE8 Memory leak

Reported by: jason@… Owned by: jason@…
Priority: low Milestone: 1.next
Component: global Version: 1.5.2
Keywords: Cc:
Blocking: Blocked by:

Description

Upon setting our companies website from 1.4.4 to 1.5.2 20-30 employees started complaining within 2-3 hours getting "out of memory error on line ##" only in IE8. As soon as I put the site back to 1.4.4 all the complaints went away.

There isn't any heavy jQuery on the site, but most of these people probably had the site sitting in the background for a while before it happened.

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to jason@…
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to global

Thanks for taking the time to contribute to the jQuery project! More information is needed to assess your ticket. It would be helpful if you could narrow down the source of the leak you are experiencing or provide a test case on  http://jsfiddle.net to ensure it is an issue with jQuery.

comment:2 Changed 3 years ago by petnys

We have had similar problems with jQuery 1.5 and IE, so we also downgraded to 1.4.4. A very simple test case is to include jQuery 1.5 in a page that is viewed inside a frame/iframe. Each time the frame is reloaded the memory usage for IE increases with a couple of MBs. Memory is only returned when the entire browser window is reloaded or closed. Changing the jQuery version to 1.4.4 removes the memory issue.

comment:3 Changed 3 years ago by timmywil

  • Status changed from pending to closed
  • Resolution set to duplicate

comment:4 Changed 3 years ago by timmywil

Duplicate of #8863.

comment:5 Changed 3 years ago by dossy

Confirmed that jQuery 1.5.2 is resulting in an "out of memory" error on the HP t5510 thin client running WinCE .NET 4.2 and IE6. Reverting to jQuery 1.4.4 seems to solve the problem - thanks.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.