Bug Tracker

Ticket #8778 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 3 years ago

siblingCheck causes unresponsive script message

Reported by: mike.malamud@… Owned by: mike.malamud@…
Priority: high Milestone: 1.next
Component: traversing Version: 1.5.2
Keywords: ie8 Cc:
Blocking: Blocked by:

Description

In IE8 when there a lot of siblings, the while loop within causes the unresponsive script message.

I am seeing this when it is called from within sortOrder.

Since IE8 does not support compareDocumentPosition, sortOrder is defined to make calls to siblingCheck

sortOrder appears to have been rewritten in 1.4.3 and prior to this, there was no problem.

Change History

comment:1 Changed 4 years ago by rwaldron

  • Keywords ie8 added
  • Owner set to mike.malamud@…
  • Status changed from new to pending
  • Component changed from unfiled to traversing

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the jQuery 0 GIT version to ensure the issue still exists.

In the case of performance issues, we recommend creating a perf test at  http://jsperf.com (be sure to use  http://code.jquery.com/jquery-git.js & jQuery.noConflict() to test against the most recent jQuery ).

comment:2 Changed 4 years ago by anonymous

Here is a jsFiddle:

 http://jsfiddle.net/thecountofzero/shMjN/7/

This must be run in IE8 and you must make sure that the following registry setting is either not set or not set to some high value that will allow scripts to run forever.

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles\MaxScriptStatements

comment:3 Changed 4 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 4 years ago by mike.malamud@…

This issue should not be closed. It is a valid issue.

I have a provided a jsFiddle that reproduces the bug.

Please reopen this bug.

Thanks.

comment:5 Changed 4 years ago by nickdk@…

I've also encountered this bug, the jsFiddle Mike provided exactly describes the issue, should be reopened.

comment:6 Changed 4 years ago by timmywil

  • Priority changed from undecided to high
  • Status changed from closed to reopened
  • Resolution invalid deleted
  • Type changed from bug to enhancement

Confirmed.  http://jsfiddle.net/timmywil/shMjN/11/ The ticket automatically closed and we missed your comment because you posted as anonymous when it was assigned to mike. No worries tho.

comment:7 Changed 4 years ago by timmywil

  • Status changed from reopened to open

comment:8 Changed 3 years ago by cmcnulty

Version 0, edited 3 years ago by cmcnulty (next)

comment:9 Changed 3 years ago by john

  • Status changed from open to closed
  • Resolution set to duplicate

comment:10 Changed 3 years ago by john

Duplicate of #7341.

Note: See TracTickets for help on using tickets.