Bug Tracker

Modify

Ticket #8693 (closed bug: invalid)

Opened 3 years ago

Last modified 2 years ago

$.get('url.html', myFunc) error : Object Required in IE 8.0.6001.18702IC

Reported by: kutio Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: git
Keywords: Cc:
Blocking: Blocked by:

Description

Hello,

When I call this $.get('url.html', myFunc), I have an error : Object Required with IE 8.0.6001.18702IC.

The function is : resolveWith: function( context, args )

and the error is on the block : "finally {".

IE error :

Détails de l’erreur de la page Web

Agent utilisateur : Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648) Horodateur : Tue, 29 Mar 2011 12:23:35 UTC

Message : Objet requis Ligne : 5641 Caractère : 12 Code : 0

I have the same error with all version of jquery.

Versions tested :

1.3 to git version ( normal version and Google Ajax API CDN, Microsoft CDN, and JQuery CDN ).

As regards,

Change History

comment:1 Changed 3 years ago by jaubourg

  • Status changed from new to closed
  • Resolution set to invalid

The problem is in myFunc and has nothing to do with $.get. Try with jQuery.noop instead of myFunc and you'll see it'll work.

comment:2 Changed 3 years ago by kutio

I found the problem :

function myFunc(data) {

$('div#myDiv').empty(); $('div#myDiv').append(data);

}

replaced by :

function myFunc(data) {

$('div#myDiv').empty(); $('div#myDiv').html(data);

}

Now it works on IE.

As regards,

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.