Bug Tracker

Modify

Ticket #8662 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

bind/live attachments to contextmenu not called when source at top of screen

Reported by: kevin@… Owned by: kevin@…
Priority: undecided Milestone: 1.next
Component: event Version: 1.5.1
Keywords: Cc:
Blocking: Blocked by:

Description

This is evident in all contextmenu plugins I could try. As far as I could debug, the function binding is not called at all when the element is in the top 20 pixels of the scrolled screen.

You can test on either of these two demos, just scroll until the demo link is at the very top of the page and try right clicking. Tested with jquery 1.5.1 and 1.1.3

 http://www.trendskitchens.co.nz/jquery/contextmenu/  http://jursza.net/dev/jjmenu/

Thank you for a great project!

Change History

comment:1 Changed 3 years ago by dmethvin

  • Owner set to kevin@…
  • Status changed from new to pending

Please provide a reduced test case so we're not debugging the plugins. Or, report the problem to the plugin authors and let them debug/reduce it.

comment:2 Changed 3 years ago by rwaldron

  • Component changed from unfiled to event

comment:3 Changed 3 years ago by addyosmani

  • Status changed from pending to closed
  • Resolution set to invalid

I've tried running the demos provided in your ticket in both latest Chrome and Firefox using the conditions you mention, but haven't been able to reproduce the issue that you're experiencing. Because we generally aren't able to help debug or fix external plugins, what I recommend doing is reporting the issue on the contextmenu bug tracker. If it's the case that others are experiencing the same problem, I'm sure that the plugin author will work away on a fix compatible with 1.5.x.That would probably be the fastest way to get it working again (unless you're familiar enough with the code to try updating it yourself).

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.