Bug Tracker

Modify

Ticket #8647 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Can't delete the attribute size with FF4

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.5.1
Keywords: needsreview Cc:
Blocking: Blocked by:

Description

The following code:

<input type="text" size="5" />
<script>
	$('input').removeAttr('size');
</script>

Gives an error at line 2065 of jquery 1.5.1:

Index or size is negative or greater than the allowed amount" code: "1 [Break On This Error] elem[ name ] = value;

This looks to happen only in FF4

Change History

comment:1 Changed 3 years ago by rwaldron

  • Keywords needsreview added
  • Status changed from new to open
  • Component changed from unfiled to attributes

Confirmed, but this is happening all the way back to jQuery 1.2.6

 http://jsfiddle.net/rwaldron/TD5gJ/

Note, Firefox is hijacking console.log, so use the "web console"

comment:2 Changed 3 years ago by rwaldron

  • Priority changed from undecided to low
  • Status changed from open to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by rwaldron

Duplicate of #8117.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.