Bug Tracker

Modify

Ticket #8576 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

PROBLEM WITH FADEIN ON IE8 and PNG

Reported by: debug@… Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.5.1
Keywords: Cc:
Blocking: Blocked by:

Description

The ticket #6412 (PROBLEM WITH FADEOUT ON IE8) was closed as invalid bug : "You can’t mix opacity and alpha-transparent images in IE unless you apply the opacity directly to an alpha-transparent <img> tag."

OK. But we use fadeOut or fadeTo to fade many divs and then fadeIn to get them normal. I think it would be better not to use alpha filter when using fadeIn or fadeTo(1). It would be more natural for the programmer if the sequence fadeOut then fadeIn would leave things unchanged. This is not the case since the PNGs get broken in the process.

I made a correction in jQuery.cssHooks.opacity, set function :

var opacity = ( jQuery.isNaN(value)
value == 1 ) ?

"" : "alpha(opacity=" + value * 100 + ")"

instead of

var opacity = jQuery.isNaN(value) ?

"" : "alpha(opacity=" + value * 100 + ")"

Thank you.

Change History

comment:1 Changed 3 years ago by dmethvin

#8577 is a duplicate of this ticket.

comment:2 Changed 3 years ago by dmethvin

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to effects

comment:3 Changed 3 years ago by ajpiano

  • Status changed from open to closed
  • Resolution set to duplicate

comment:4 Changed 3 years ago by ajpiano

Duplicate of #6652.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.