Bug Tracker

Modify

Ticket #8411 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Selecting of checkboxes different under 1.4.4 and 1.5 or above

Reported by: LaySoft Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocking: Blocked by:

Description

I have two checkboxes:

<input type="checkbox" id="x"/> <input type="checkbox" id="x:y"/>

under jQuery 1.4.4

$(':checkbox[id=x:]').attr('checked','checked');

and

$(':checkbox[id=x\:]').attr('checked','checked');

checks only second checkbox.

But under jQuery 1.5 and 1.5.1 checks both checkboxes.

Change History

comment:1 Changed 3 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 3 years ago by addyosmani

Duplicate of #8410.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.