Bug Tracker

Ticket #8351 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Regresion in Attribute selector

Reported by: digitalxero@… Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

Having '/' in an attribute use to work while selection on that attribute in 1.4.4

 http://jsfiddle.net/KxCmC/1/

But in 1.5.0 you get uncaught exception: Syntax error, unrecognized expression: [option=Test/This]

 http://jsfiddle.net/cTJ7N/3/

Change History

comment:1 Changed 4 years ago by digitalxero@…

This also affects attributes that have a . in the value eg: option="3.6" cannot be selected via jQuery('[option=3.6]')

comment:2 Changed 4 years ago by digitalxero@…

Updated the examples

Working (1.4.4)  http://jsfiddle.net/KxCmC/2/

Exception (1.5.0)  http://jsfiddle.net/cTJ7N/4/

comment:3 Changed 4 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to selector

None of the selector in your test case are - and never were - valid selectors (except the TestThis).

That these worked in earlier versions of jQuery was actually a bug that got fixed in 1.5. This is clearly pointed out in the documentation, so that I don't need to repeat my self check this comment

comment:4 Changed 4 years ago by jitter

Duplicate of #8229.

Note: See TracTickets for help on using tickets.