Bug Tracker

Modify

Ticket #8239 (closed bug: worksforme)

Opened 3 years ago

Last modified 2 years ago

The character 't' is visible after scrolling and refreshing a page on the iPad.

Reported by: RoyceG Owned by:
Priority: low Milestone: 1.next
Component: support Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by jitter) (diff)

The character 't' is visible after scrolling and refreshing a page on the iPad.

How to reproduce:

Use this html:

<!doctype html>
<html>
<head>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.min.js" type="text/javascript"></script>
</head>
<body style="color: Red; font-size: 400px; height: 2000px;"></body>
</html>

On an iPad scroll down the page and then hit refresh. You should see a big red 't' on the page. This only occurs when the page is scrolled.

The 't' is coming from line 1442(uncompressed)in the jQuery.support section.

div.innerHTML = "<table><tr><td style='padding:0;border:0;display:none'></td><td>t</td></tr></table>";

Change History

comment:1 Changed 3 years ago by ajpiano

#8240 is a duplicate of this ticket.

comment:2 Changed 3 years ago by jitter

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to support
  • Description modified (diff)

Confirmed by eTiger13 check this video for evidence

 http://www.youtube.com/watch?v=NVw5pEAH8Pw

comment:3 Changed 3 years ago by jitter

  • Priority changed from high to low

comment:4 Changed 3 years ago by jaubourg

Just wondering if support tests couldn't be done in an iframe? I know you can attach it to the head element and still access its document (tested on jQuery-JSONP 1.x). Would also remove the need for a domReady handler to assess boxModel-related properties.

comment:5 Changed 3 years ago by addyosmani

  • Status changed from open to closed
  • Resolution set to worksforme

Tested using jQuery 1.6 -> jQuery (edge) on a live iPad and haven't been able to reproduce this using the latest version of iOS. Closing due to not being able to reproduce behaviour.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.