Bug Tracker

Modify

Ticket #8233 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Select box with lots of optios inside dialog return script loop error on IE with min 1.4.4 (but not with 1.4.2)

Reported by: ramanan@… Owned by: ramanan@…
Priority: low Milestone: 1.next
Component: traversing Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Error details: . min 1.4.4 . select boxes with lots of options . IE only . when inside dialog, only

The error is a javascript loop error like when we click on select to expand the options. IE ask us to stop the the loop script and select never drops dow. But we can navigate on select with arroy keys, so, select is design but we can not drop it dow.

Change History

comment:1 Changed 3 years ago by jitter

  • Owner set to ramanan@…
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on  http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


 How to report bugs

comment:2 follow-up: ↓ 3 Changed 3 years ago by ratibus@…

We have the same problem here since we upgraded from 1.4.2 to 1.4.4. It is related to this issue : #7341

When you use jQuery dialog, it uses jquery.ui.mouse.js which in turn calls add() in the following code :

elIsCancel = (typeof this.options.cancel == "string" ? $(event.target).parents().add(event.target).filter(this.options.cancel).length : false);

And when you have <select> with lot of options (like we do), it slows down IE to the point that it is unusable. It works with no problems in other browsers since sortOrder implementation is different.

comment:3 in reply to: ↑ 2 Changed 3 years ago by jitter

  • Priority changed from undecided to low
  • Component changed from unfiled to traversing

Replying to ratibus@…:

We have the same problem here since we upgraded from 1.4.2 to 1.4.4. It is related to this issue : #7341

When you use jQuery dialog, it uses jquery.ui.mouse.js which in turn calls add() in the following code :

elIsCancel = (typeof this.options.cancel == "string" ? $(event.target).parents().add(event.target).filter(this.options.cancel).length : false);

And when you have <select> with lot of options (like we do), it slows down IE to the point that it is unusable. It works with no problems in other browsers since sortOrder implementation is different.

This sounds more like a bug in jQuery UI. You should file the bug on the  jQuery UI Bug Tracker and include the following related links

comment:4 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.