Bug Tracker

Modify

Ticket #8172 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

jQuery resets Firefox toolbars when used in add-ons

Reported by: Propeng Owned by:
Priority: low Milestone: 1.next
Component: support Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

When jQuery is inserted inside an XUL overlay of chrome://browser/content/browser.xul, the main Firefox XUL window, all changes to the Firefox toolbars are not visible. Disabling jQuery shows these changes again.

Steps to reproduce:

  1. Make changes to a Firefox toolbar, such as changing the order of buttons.
  2. Install the attached sample add-on, which is a simple XUL browser.xul overlay with jQuery 1.5.
  3. Restart Firefox. Notice that the changes to the toolbars you made in step 1 are reset.
  4. Uninstall the sample add-on ("jQuery Test").
  5. Restart Firefox again. The changes are now visible.

Change History

comment:1 Changed 3 years ago by propeng

I wasn't able to attach it, so you can download it at:  http://propeng.hopto.org/misc/jquerybug/jquerytest.xpi

comment:2 Changed 3 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to support

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

This isn't a bug, as jQuery isn't officially supported to work in the XUL environment. These bugs are also known and can be easily found by searching for XUL on this bug tracker.

You may want to take a look at #5206, #5776 and #4794. And track the ticket mentioned below for an eventual progress on this issue.

Version 0, edited 3 years ago by jitter (next)

comment:3 Changed 3 years ago by jitter

Duplicate of #5206.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.