Bug Tracker

Ticket #8167 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

Solution for incorrect left, top, width, height css when $(obj) is hidden

Reported by: svcorp77 Owned by:
Priority: low Milestone: 1.next
Component: css Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by rwaldron) (diff)

See  http://jsfiddle.net/addyosmani/F9LKa/

The 1.4.2 output of your code is:

display: block; width: 100px; height: 100px; left: 100px; top: 100px; position: absolute; opacity: 0; overflow: hidden; 100px 100px animation complete display: block; width: 420px; height: 150px; left: 38px; top: 97px; position: absolute; opacity: 1; 38px 97px

The 1.4.3 output is:

display: none; width: 100px; height: 100px; left: 0px; top: 0px; position: absolute; opacity: 0; overflow: hidden; 0px 0px animation complete display: none; width: 420px; height: 150px; left: 38px; top: 97px; position: absolute; opacity: 1; 0px 0px

And the Current Git Version output is:

display: none; width: 100px; height: 100px; left: 0px; top: 0px; position: absolute; opacity: 0; overflow: hidden; 0px 0px animation complete display: none; width: 420px; height: 150px; left: 38px; top: 97px; position: absolute; opacity: 1; 0px 0px

Here is solution for:
jQuery JavaScript Library v1.5, string 7610, function jQuery.fx.prototype.update
jQuery version > 1.4.3: the same mods.

                // Set display property to block for height/width animations
		if ( ( this.prop === "height" || this.prop === "width" ) && this.elem.style ) {
			this.elem.style.display = "block";
		}

Please, make this changes next update.

Change History

comment:1 Changed 4 years ago by rwaldron

  • Description modified (diff)

comment:2 Changed 4 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to css

comment:3 Changed 4 years ago by jitter

Duplicate of #7305.

Note: See TracTickets for help on using tickets.