Bug Tracker

Modify

Ticket #8139 (closed bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

IE 9 not suported getElementsByTagName when load content

Reported by: svcorp77 Owned by:
Priority: blocker Milestone: 1.5.1
Component: manipulation Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

jQuery.clone function
bug when IE 9 try to load content from web:

$('<div>Try to load content</div>')
	.load('http://bugs.jquery.com/report', function() {
		alert('OK');
	}); 


FIX:

			// Using Sizzle here is crazy slow, so we use getElementsByTagName
			// instead
			// but for IE Sizzle for sure-)
			if ("getElementsByTagName" in elem ) {
				srcElements = elem.getElementsByTagName("*");
				destElements = clone.getElementsByTagName("*");
			}else{
				srcElements = $('*', elem).get();
				destElements = $('*', clone).get();
			};

Change History

comment:1 Changed 3 years ago by jitter

  • Priority changed from undecided to blocker
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to manipulation
  • Milestone changed from 1.next to 1.5.1

comment:2 Changed 3 years ago by jitter

Duplicate of #8052.

comment:3 Changed 2 years ago by anonymous

thanks this fixed a glitch on my site

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.