Bug Tracker

Ticket #8134 (closed bug: invalid)

Opened 4 years ago

Last modified 3 years ago

Internet Explorer (64-bit) and 32-bit

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0) Timestamp: Tue, 1 Feb 2011 22:01:39 UTC

Message: Unexpected call to method or property access. Line: 16 Char: 55207 Code: 0 URI:  http://code.jquery.com/jquery-1.5.min.js

Message: Unexpected call to method or property access. Line: 16 Char: 55207 Code: 0 URI:  http://code.jquery.com/jquery-1.5.min.js

Change History

comment:1 Changed 4 years ago by rwaldron

  • Owner set to anonymous
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the jQuery 0 GIT version to ensure the issue still exists.

Be sure to use a non-minified version of jQuery.

comment:2 Changed 4 years ago by rwaldron

Likely a duplicate of #8052

comment:3 Changed 4 years ago by jitter

I don't think so. Looks like the code in question is inside the .append() method. The this.nodeType check. But we need a test case!

comment:4 Changed 4 years ago by roelf

I'm using the non-minified version, and the error is at line 5072, char 21, so indeed the this.nodeType check. I'll try to deduct a test case from my current code. btw this happens in IE, not FF or Chrome. I'm using IE8+compatibility mode.

comment:5 Changed 4 years ago by anonymous

  • Status changed from pending to new

Running this code:

$(document).ready(function(){

Loop each construct tag $('construct').each(

function () {

Grab data var jC2_events = $(this).html().split('\n'); $(this).html();

Data var jC2_html = ;

Add wrapper tags jC2_html += '<div class="jC2_Outer">'; jC2_html += '<div class="jC2_Toolbar">';

jC2_html += '<div class="jC2_HelpBox"><a href="#">Txt</a></div>';

jC2_html += '<div class="jC2_HelpBox"><a href="#">?</a></div>'; jC2_html += '</div>'; jC2_html += '<div class="jC2_Container">';

var jC2_EventNum = 1;

Loop each event for(var jC2_looper = 0; jC2_looper < jC2_events.length; jC2_looper++) {

Check for blank lines (first condition in if is IE fix) if(jC2_events[jC2_looper] && jC2_events[jC2_looper].trim().length > 0) {

var jC2_eventData = jC2_events[jC2_looper].trim();

Check for comment if(jC2_eventData.substring(0,1) == '#'){

jC2_html += '<div class="jC2_EventComment">' + jC2_eventData.substring(1,jC2_eventData.length) + '</div>';

}else{

Split event into components var jC2_components = jC2_events[jC2_looper].split(':');

Event wrapper jC2_html += '<div class="jC2_EventNum">' + jC2_EventNum + '</div>' jC2_html += '<div class="jC2_EventWrapper">';

jC2_html += '<div class="jC2_EventObject">' + jC2_components[0].trim() + '</div>'; jC2_html += '<div class="jC2_EventBreak"></div>'; jC2_html += '<div class="jC2_EventDesc">' + jC2_components[1].trim() + '</div>';

jC2_html += '</div>';

Actions jC2_html += '<div class="jC2_ActionWrapper">';

Loop remaining params var jC2_actionCount = 0; for(var jC2_looper2 = 2; jC2_looper2 < jC2_components.length; jC2_looper2++) {

var jC2_actionData = jC2_components[jC2_looper2].trim();

Check for comments if(jC2_actionData.substring(0,1) == "#"){

jC2_html += '<div class="jC2_ActionComment">' + jC2_actionData.substring(1, jC2_actionData.length) + '</div>';

} else {

var jC2_actionClass; if((jC2_actionCount%2) == 0){

jC2_actionClass = 'jC2_Odd';

}else{

jC2_actionClass = 'jC2_Even';

}

jC2_html += '<div class="jC2_ActionLeft"></div>'; jC2_html += '<div class="jC2_ActionDesc ' + jC2_actionClass + '">' + jC2_actionData + '</div>'; jC2_html += '<div class="jC2_Clear"></div>'; jC2_actionCount++

}

}

jC2_html += '</div><div class="jC2_Clear"></div>'; jC2_EventNum++;

}

}

}

End wrappers jC2_html += '</div>'; jC2_html += '<div class="jC2_FooterInfo"><div class="jC2_Scirra"><a class="jC2_AS" href=" http://www.scirra.com">Scirra.com</a> - Software in Motion</div>Generated with <a class="jC2_AF" href=" http://www.scirra.com">JConstruct 1.0</a></div>'; jC2_html += '</div>'; $(this).html(jC2_html);

}

);

});

With this HTML:

<construct>

System:Every tick:Set width to Y-100:#A comment:Set angle to Atan(Self.X-Mouse.X):Finish it #This is a comment Sprite:On event:Do this:Do that:Do something else Clock:Ticks and chimes:Do something:Do it again!:Add one

</construct>

Throws the error in IE

comment:6 Changed 4 years ago by snover

  • Status changed from new to pending

Pasting code in the ticket is not a useful test case. Please follow the bug reporting guidelines and use jsFiddle.

comment:7 Changed 4 years ago by ottuzzi

I can reproduce this problem too on IE8. On  http://stackoverflow.com/questions/5023674/jquery-throws-ie-specific-error they suggest that this is a problem about IE8 not handling try/finally block without catch in function resolveWith but the suggested fix does not seem to work for me. Please consider that I am an absolutely noob in JS!

Thanks Piero

comment:8 Changed 4 years ago by ottuzzi

Using the non-minified version of jQuery I had a tip from IE8 indicating a known KB article  http://support.microsoft.com/kb/927917/en-us pointing on my own error.

comment:9 Changed 4 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:10 Changed 3 years ago by alper.tayfun@…

i'm using ie8 and latest jquery file.

But getting error below :

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E) Timestamp: Wed, 13 Apr 2011 08:05:15 UTC

Message: Exception thrown and not caught Line: 16 Char: 40245 Code: 0 URI:  http://code.jquery.com/jquery-latest.min.js?_=1302681863043

comment:11 Changed 3 years ago by gungui

I use ie7 and jquery.min.js version 1.5.2 Same error at Line: 16 Microsoft Script Debugger break at the finally statement.

Note: See TracTickets for help on using tickets.