Bug Tracker

Ticket #8127 (closed bug: duplicate)

Opened 4 years ago

Last modified 2 years ago

$.ajax does not work on local machine

Reported by: anonymous Owned by: anonymous
Priority: high Milestone: 1.5.1
Component: ajax Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

In IE 6,7,8,9 requesting files using $.ajax on a file on the local machine with a path " file:///" does not work. It returns with error "Unknown".

In jQuery 1.4.4 this worked as long as the js execution context was also from the local machine

Change History

comment:1 Changed 4 years ago by chris.rudmin@…

I should note as well that I am using absolute paths. For example  file:///c:/foo.html

comment:2 Changed 4 years ago by addyosmani

  • Owner set to anonymous
  • Status changed from new to pending

Could you please supply us with a reduced test case so we can see what code you're using to achieve this? - IE has some known gotchas when it comes to local file access but I can't advise further until I see what you've written. Because it's local, feel free to send us over a file (however jsFiddle.net still works - we can always just copy the code out ourselves).

comment:3 Changed 4 years ago by danheberden

  • Status changed from pending to closed
  • Resolution set to duplicate

8

Version 0, edited 4 years ago by danheberden (next)

comment:4 Changed 4 years ago by danheberden

Duplicate of #8125.

comment:5 Changed 4 years ago by jitter

  • Priority changed from undecided to high
  • Component changed from unfiled to ajax
  • Milestone changed from 1.next to 1.5.1

comment:6 Changed 4 years ago by anonymous

There's no specific code need, just the standaard $.get() and $.ajax() return "unknown".

Note: See TracTickets for help on using tickets.