Bug Tracker

Modify

Ticket #8112 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Set "name" attribute using attr doesn't work on IE 8

Reported by: carloseugenio@… Owned by: carloseugenio@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.5
Keywords: Cc:
Blocking: Blocked by:

Description

Hi! This code:

	//Getting the checkbox
	var checkbox = $row.find(':checkbox');
	//Change the checkbox id and name
	checkbox.attr('id', 'disassociate-questions');
	checkbox.attr('name', 'disassociate-questions');
	var row_html_to_add = $row.html();
	alert("Row html: " + row_html_to_add);

Alerts only id attribute changed to the new value. The attribute name doesn't change on IE8. In Chrome and Firefox it works correctly.

Regards. Carlos Eugênio.

Change History

comment:1 Changed 3 years ago by danheberden

  • Owner set to carloseugenio@…
  • Status changed from new to pending
  • Component changed from unfiled to attributes

Thanks for taking the time to make a bug report! Please make sure you've follow the steps outlined in our bug reporting guide (  http://docs.jquery.com/How_to_Report_Bugs ) which includes making a distilled, runnable test-case on jsfiddle.net.

Looking forward to seeing the demo of your bug.

comment:2 Changed 3 years ago by danheberden

  • Status changed from pending to closed
  • Resolution set to invalid

Went ahead and made a test case: works fine in IE8 (7, and 6 too) and chrome, etc .

Hope this helps narrow down your problem. I suspect there is an error in your app somewhere.

 http://jsfiddle.net/danheberden/DM5t7/

Version 1, edited 3 years ago by danheberden (previous) (next) (diff)

comment:3 Changed 3 years ago by jitter

  • Priority changed from undecided to low

comment:4 Changed 3 years ago by anonymous

Sorry for not have seen the the bug reporting guide before. Nevertheless, I couldn't reproduce in jsfiddle either. I will double check what might have happened here.

Thanks for the time.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.