Bug Tracker

Modify

Ticket #8107 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

jQuery.ajax fails when only the URL parameter is provided

Reported by: danheberden Owned by: danheberden
Priority: low Milestone: 1.5.1
Component: ajax Version: 1.5
Keywords: Cc: jaubourg
Blocking: Blocked by:

Description (last modified by danheberden) (diff)

$.ajax( 'url' ); fails with

Chrome:
Uncaught TypeError: Cannot use 'in' operator to search for 'context' in /echo/html

FF4:
Error: invalid 'in' operand options
Source File: http://code.jquery.com/jquery-git.js
Line: 6352

If the settings object (even if just {} ) is present, it works fine. Also, looks like unit tests passed cuz it was just calling $.ajax();

 http://jsfiddle.net/danheberden/u9qsW/

Change History

comment:1 Changed 3 years ago by danheberden

  • Cc jaubourg added
  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to ajax
  • Description modified (diff)

comment:2 Changed 3 years ago by danheberden

  • Description modified (diff)

comment:3 Changed 3 years ago by rwaldron

  • Owner set to danheberden
  • Status changed from open to assigned

Confirmed

comment:5 Changed 3 years ago by danheberden

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:6 Changed 3 years ago by jitter

  • Milestone changed from 1.next to 1.5.1

comment:7 Changed 3 years ago by timmywil

Ah cool, just found this bug myself.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.