Bug Tracker

Modify

Ticket #7975 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

filter() behavior is different when source is single dom vs multiple dom nodes

Reported by: coli@… Owned by:
Priority: low Milestone: 1.4.4
Component: traversing Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

I have a bunch of <li data-id="0-0"/> <li data-id="0-1"/> etc

$("li").filter("[data-id=0-0]") returns the 1 matching node

$("li").filter("[data-id=0-0]").filter("[data-id=0-0]") returns empty! It should return that 1 node.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by anonymous

never mind, looks like it's fixed in 1.4.4

comment:2 in reply to: ↑ 1 Changed 3 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to fixed
  • Status changed from new to closed
  • Component changed from unfiled to traversing
  • Milestone changed from 1.next to 1.4.4

Thanks for taking the time to contribute to the jQuery project by writing a bug report. I tried to reproduce the bug you described but wasn't able to do so. Even when using older jQuery versions. Could you please provide a test case on  http://jsfiddle.net to verify when this issue occured/was fixed.

Replying to anonymous:

never mind, looks like it's fixed in 1.4.4

Closing as requested by the reporter.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.