Bug Tracker

Ticket #7957 (closed bug: invalid)

Opened 4 years ago

Last modified 3 years ago

find returns Failed on IE8 with selector

Reported by: learnerplates Owned by: learnerplates
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

$("#Application-NavBar").find("[id]:visible:enabled");

returns Failed on IE8 and returns a result on Chrome.

The following also fails $(self.handle()).find("[id]:visible:enabled");

self.handle() is part of a form.

Change History

comment:1 Changed 4 years ago by addyosmani

  • Owner set to learnerplates
  • Status changed from new to pending

Thanks for submitting a ticket to the jQuery Bug Tracker!

In order for us to fully evaluate the bug you are experiencing, please provide us a reduced test case that reproduces this behavior on  http://jsfiddle.net.

comment:2 Changed 4 years ago by niall <nfallon@…>

the is() function works with the same selectors after I have executed a find using the "[id]" selector. This proves to me that the query is correct, Find() is where the issue lies on IE8.

var found = [];

$.each($(self.handle()).find("[id]"), function (index, value) {

if ($(value).is(":visible:enabled"))

found.push(value);

} );

comment:3 Changed 4 years ago by niall <nfallon@…>

workaround for now is ($(self.handle()).find("[id]").filter(":visible:enabled"));

comment:4 Changed 4 years ago by jitter

As already noted by addyosmani. In order for us to fully evaluate the bug you are experiencing, please provide us a reduced test case that reproduces this behavior on  http://jsfiddle.net (html/css/js)

comment:5 Changed 4 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.