Bug Tracker

Ticket #7951 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

Bug with animate background-position on IE8

Reported by: ludosoms@… Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Code animate

$('.pub-images').animate({
  backgroundPosition: '-' + (this.pageWidth * page) + 'px 0' //Example : 450 * 2
},
this.pageSlideTime * ((this.pageActive > page) ? this.pageActive - page : page - this.pageActive), //Example : 500 * 2
function() {			
  //Active page marker
  mi.pub.pageActive = page;
});

IE8 report

Agent utilisateur : Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)
Horodateur : Wed, 12 Jan 2011 09:56:06 UTC

Message : Argument non valide.
Ligne : 6775
Caractère : 5
Code : 0
URI : http://127.0.0.1/**************/js/jquery.js?version=20101216155024

--------------------------------------------------------------------

Work on FF, Chrome and Safari !

Change History

comment:1 Changed 4 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to effects

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

In short: jQuery doesn't support animating the background-position property. For a more in depth answer please check my comment on the ticket referenced below.

comment:2 Changed 4 years ago by jitter

Duplicate of #7755.

Note: See TracTickets for help on using tickets.