Bug Tracker

Ticket #7942 (closed bug: worksforme)

Opened 4 years ago

Last modified 4 years ago

I cant download Jquery 1.4.4!

Reported by: lanyonjohn@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

I am trying to download the latest version of jquery (1.4.4) from the jquery.com homepage and it is NOT working. When I click the 'download(jquery);' button my browser fills with code and does not link me to the correct page/file.

Change History

comment:1 Changed 4 years ago by rwaldron

  • Status changed from new to closed
  • Resolution set to worksforme

That IS jQuery. Copy and paste that into a file and name it jquery-1.4.4.min.js

comment:2 Changed 4 years ago by ev149

jQuery is code, that's what it's supposed to be. Just hit CMD/CTRL + S to download it.

comment:3 Changed 4 years ago by SlexAxton

I can confirm this behavior.

comment:6 Changed 4 years ago by jdalton

Classy mocking the OP :(

The problem is because the file isn't being sent with the proper headers. Compare the jQuery.com download behavior with this  link

comment:7 Changed 4 years ago by gf3

Content-Disposition: Attachment headers might be handy, but I think I'd opt for simply changing the button text.

comment:8 Changed 4 years ago by anonymous

just save as .js dumb neds

comment:9 Changed 4 years ago by musicisair

PLEASE PLEASE PLEASE don't add the "force-download" headers. People can right click and "Save As" or they can Ctrl+S the source (er, browser full of code). You can't easily tell your browser to act like view-source on a download attachment.

comment:10 Changed 4 years ago by rwaldron

#8265 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.