Bug Tracker

Modify

Ticket #7890 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

add class ui effects don't work with 1.4.4

Reported by: cypr.vb@… Owned by:
Priority: low Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Add class ui effects don't work with 1.4.4. They don't work on the website examples either:  http://jqueryui.com/demos/addClass/default.html

Change History

comment:1 Changed 3 years ago by addyosmani

  • Priority changed from undecided to low
  • Status changed from new to closed
  • Resolution set to invalid

Thank you for submitting a ticket to the jQuery Bug Tracker!

It would appear that using jQuery 1.4.4 and jQuery UI 1.8.5 on jsFiddle.net  Live Test Case works fine, however when using 1.8.7  here it breaks.

Please note that although this is the case, the tracker you submitted your bug on is for core bugs only and you will need to re-submit your ticket to the jQuery UI Bug Tracker for further assistance as they handle all UI-related tickets. Thanks!

comment:2 Changed 3 years ago by ajpiano

This is fixed in the latest revisions of jQuery UI.

You can fix this for UI 1.8.7 with the following one-line fix.

var e=$.effects,a=e.animateClass;e.animateClass=function(){this.delay(0);return a.apply(this,arguments);};

comment:3 Changed 3 years ago by ajpiano

#7905 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.