Bug Tracker

Modify

Ticket #7877 (closed bug: wontfix)

Opened 3 years ago

Last modified 2 years ago

getData/setData/changeData events need tech review and docs

Reported by: dmethvin Owned by:
Priority: high Milestone: 1.6
Component: web Version: git
Keywords: Cc:
Blocking: Blocked by:

Change History

comment:1 Changed 3 years ago by dmethvin

  • Priority changed from undecided to high
  • Version changed from 1.4.4 to git
  • Component changed from unfiled to data
  • Milestone changed from 1.next to 1.5

comment:2 Changed 3 years ago by snover

#7573 is a duplicate of this ticket.

comment:3 Changed 3 years ago by snover

  • Status changed from new to open

I think they should be removed. They are slow, inconsistent to other events, and could be duck punched in by anyone that needs them.

comment:4 Changed 3 years ago by jitter

  • Milestone changed from 1.5 to 1.6

I'm not totally against removing them. We should bring this on for the 1.6 roadmap, maybe deprecate for 1.6/1.7 and then sometime remove'em + compat plugin.

In the meantime I propose something like  this to speed up $.fn.data. This way $.fn.data would only be 2x-3x slower then $.data if no one listens to the data-events.

comment:5 Changed 3 years ago by john

  • Keywords needsdocs added
  • Resolution set to wontfix
  • Status changed from open to closed
  • Component changed from data to web

Since we've decided to keep the events, I'm closing this and adding the needsdocs keyword so that we can tackle that later.

comment:6 Changed 3 years ago by addyosmani

  • Keywords needsdocs removed

Having spoken to Dave and Karl regarding this, there appear to be some oppositions to us documenting these methods at the moment. I'll be removing the needsdocs tag until a point where we decide to document them again.

comment:7 Changed 3 years ago by denver.root@…

To anyone who might be concerned with my opinion: In the release notes for 1.4.3 you noted changes to two of these functions, and introduced the third. I am positive that these are useful functions, but the utter lack of documentation limits their adoption, and honestly, ambiguates "your" official position on whether or not anyone should use them. In our communities, as you well know, when a feature is undocumented, we tend to avoid it, even when it proves to be incredibly useful, because we don't want to introduce regressions later when the feature unexpectedly disappears...

From one programmer to another, please either document these features, or remove them, so it's not ambiguous to all of us out here whether or not they will be dependable. I'd much rather just write a plugin to do this same thing, but don't want to duplicate your work if it's sticking around...

Thanks :)

(you're doing a great job)

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.