Bug Tracker

Modify

Ticket #7861 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

FF 3.6.13 attempt to get the css("left") value

Reported by: anonymous Owned by: anonymous
Priority: low Milestone:
Component: css Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

for example: set $("#element").css({left:100, width:400});

get for this $("#element").attr("style") - return "left:100px; width:400px"

try get value for "width" $("#element").css("width") - return "400px" but for "left" value $("#element").css("left") - return "0px"

Change History

comment:1 Changed 3 years ago by sergioneli@…

<div id="element" style="position:absolute"></div>

for example: set $("#element").css({left:100, width:400});

get for this $("#element").attr("style") - return "position: absolute; left: 100px; width: 400px;" - ok

$("#element").css("width") - return "400px" - ok

$("#element").css("left") - return "0px" - ? $("#element").position().left = return 0 - ? $("#element").position().offset() - return 0 - ?

but $("#element").style.left - return 100

comment:2 Changed 3 years ago by snover

  • Owner set to anonymous
  • Status changed from new to pending

As per the bug reporting instructions in the big red box, please provide a test case on  jsFiddle.

comment:3 Changed 3 years ago by sergioneli@…

comment:4 Changed 3 years ago by jitter

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from pending to closed
  • Component changed from unfiled to css
  • Milestone 1.6 deleted

Thanks for the test case. As there is way more information on this issue on a newer ticket I close this one as duplicate. See the ticket mentioned below for progress on this issue.

comment:5 Changed 3 years ago by jitter

Duplicate of #7871.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.