Bug Tracker

Ticket #7788 (closed bug: invalid)

Opened 4 years ago

Last modified 4 years ago

Error thrown when closest() calls matchesSelector method

Reported by: dygerati@… Owned by: dygerati@…
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

Error is as follows: expr.replace is not a function

This occurs due to the closest method calling calling jQuery.find.matchesSelector() with improperly typed arguments. The second parameter (selectors), should be passed as a string, but is an object.

At least I think that's whats going on :D.

This offending line is 4424 in uncompressed 1.4.4.

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by jitter

  • Owner set to dygerati@…
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project by writing a bug report but with information you provided it is not possible to determine if there is a bug.

So please submit a reduced test case, which reproduces the issue you are experiencing, on  http://jsfiddle.net. Then we will be happy to investigate this issue further.


 How to report bugs

comment:2 in reply to: ↑ 1 Changed 4 years ago by anonymous

Honestly, I'm just not certain under what circumstances that part of the closest method is executed. There are hundreds of calls to matchesSelector() in our environment and only those originating from the closest method seem to exhibit this issue. It's clear if you look at the offending code that the parameters passed are of the wrong type.

Thanks, Joel T

Replying to jitter:

Thanks for taking the time to contribute to the jQuery project by writing a bug report but with information you provided it is not possible to determine if there is a bug.

So please submit a reduced test case, which reproduces the issue you are experiencing, on  http://jsfiddle.net. Then we will be happy to investigate this issue further.


 How to report bugs

comment:3 Changed 4 years ago by ajpiano

Surely you can create something on jsFiddle that simulates the conditions of your environment and shows the same error? That's all we need to continue...

(Hint: Use the Stack Trace in your debugger when the code throws an error to find which line of your own code invoked it)

If you can't, then it's very hard for us to see what's going wrong, or if it is just a problem with your environment or page.

comment:4 Changed 4 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.