Bug Tracker

Modify

Ticket #7786 (closed bug: worksforme)

Opened 3 years ago

Last modified 3 years ago

Safari 3.0.2 quickExpr unicode

Reported by: anonymous Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

In Safari 3.0.2 the following thing will produce an exception:

jQuery("<div>ƒ</div>"); (happens also with other unicode chars)

Exception is : "Syntax error, unrecognized expression: >"

The problem seems to be the quickExpr, which does not match if there are some unicode chars and so jQuery thinks that it is a query and tries to execute it.

jQuery("body").append("<div>ƒ</div>"); works without a problem.

Change History

comment:1 Changed 3 years ago by jitter

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for taking the time to contribute to the jQuery project by writing a bug report. As you didn't provide a test case with your ticket I made one myself.  test case

I tried this test case with Safari 3.1 and 3.1.2 and there was no error, so I couldn't reproduce your problem. Please report back if you can provide a reproducible test case ( http://jsfiddle.net) then we can further evaluate this ticket.

If I'm correct Safari 3.0.2 is:

  • not a stable release
  • a beta version
  • 3+ years old
  • not the latest version on the 3.X branch

Considering this alone makes it look unlikely that this bug gets fixed unless it is trivial or you can show this is a bug in jQuery and not the browser regexp evaluation.


 How to report bugs

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.